因工作中接触到N9K的设备,但是能看到的文档都是中文版,查无可查,所以记录一次具体项目中涉及到的命令,供一起交流学习。

1、修改设备名称

test# conf t

Enter configuration commands, one per line. End with CNTL/Z.

test(config)# hostname cisco-N9K

cisco-N9K(config)# end

2、开启配置信息

cisco-N9K(config)# feature telnet

cisco-N9K(config)# feature ospf

cisco-N9K(config)# feature bgp

cisco-N9K(config)# feature ospfv3

cisco-N9K(config)# feature eigrp

cisco-N9K(config)# feature interface-vlan

cisco-N9K(config)# feature dhcp

cisco-N9K(config)# feature vtp

3、创建vlan给管理地址

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# interface vlan 188

cisco-N9K(config-if)# ip address 192.168.100.1 255.255.255.0

cisco-N9K(config-if)# no shutdown

cisco-N9K(config-if)# end

默认vlan1   同理

4、查看vlan信息

cisco-N9K# show vlan brief

此图像的alt属性为空;文件名为微信截图_20190916142245.png

5、添加静态路由

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# ip route 0.0.0.0 0.0.0.0 10.100.0.1

cisco-N9K(config)# end

6、端口添加到vlan

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# interface e1/10

cisco-N9K(config-if)# sw

cisco-N9K(config-if)# sw access vlan 188

cisco-N9K(config)# end

7、创建端口聚合

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# interface port-channel 300

cisco-N9K(config-if)# sw

cisco-N9K(config-if)# no shutdown

cisco-N9K(config-if)# sw acc vlan 200

cisco-N9K(config-if)# end

8、端口添加到链路聚合组

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# interface e1/10

cisco-N9K(config-if)# sw

cisco-N9K(config-if)# sw acc vlan 200

cisco-N9K(config-if)# channel-group 188

cisco-N9K(config-if)# end

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# interface e1/11

cisco-N9K(config-if)# sw

cisco-N9K(config-if)# sw acc vlan 200

cisco-N9K(config-if)# channel-group 188

cisco-N9K(config-if)# end

cisco-N9K#

9、查看端口聚合信息

cisco-N9K# show port-channel summary

10、修改端口mtu值

cisco-N9K# conf t

Enter configuration commands, one per line. End with CNTL/Z.

cisco-N9K(config)# interface e1/10

cisco-N9K(config-if)# mtu 9216

cisco-N9K(config-if)# end

11、查看设备版本信息

cisco-N9K # show version

12、查看主机表

cisco-N9K # show hosts

13、查看设备所有配置

cisco-N9K # show running-configure

14、配置保存命令

cisco-N9K# copy running-config startup-config

备注:

思科除了N9K产品需要优先开启cisco-N9K(config)# feature telnet

cisco-N9K(config)# feature ospf

cisco-N9K(config)# feature bgp

cisco-N9K(config)# feature ospfv3

cisco-N9K(config)# feature eigrp

cisco-N9K(config)# feature interface-vlan

cisco-N9K(config)# feature dhcp

cisco-N9K(config)# feature vtp这些服务之外,其它的配置命令和思科常用命令通用

发表评论

电子邮件地址不会被公开。 必填项已用*标注